Category Archives: xDSL

DownStream Power Back Off (DPBO) and our Cisco gear

I love my Job 😉

We discovered a new Feature on the DSL Lines. It is called DownStream Power Back Off, this feature was introduced in November 2007 and is currently only supported on German Telekom lines. Where as the ADSL2+ specifcation is from 2004. The Ciscos have implementet the specifcation from 2004 and today no router supports the 2007 specs. So if you are useing Cisco Hardware have a look here to see if your router supporting it.

If you feel this helps a bit or may be not ? Please leave a comment.

Flickr : , , ,

VDSL

Das Thema Cisco Router mit einem von den neuen VDSL Anschlüssen ans rennen
zu bekommen ist nicht weiter schwierig.

Hier ein paar Beispiele:

Bei Routern die nur einen eingebauten Switch besitzen, z.B. Cisco 876:

[sourcecode]
!— snip —
vlan 7
name VDSL-VLAN
!
interface FastEthernet 8
switchport mode trunk
switchport trunk allowed vlan 1,7,1002-1005
!
interface Vlan 7
description VLAN fuer VDSL
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer 0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username <user>@t-online.de password 0 <password>
!
!— snip —
[/sourcecode]

Bei anderen Modellen kann man auch eines der Routing interface nehmen.
[sourcecode]
!— snip —
interface FastEthernet 0.7
encapsulation dot1q 7
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer 0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username <user>@t-online.de password 0 <password>
!
!— snip —
[/sourcecode]

VDSL mit Cisco Routern

[sourcecode]
!
interface FastEthernet3
description WAN to VDSL-Modem
switchport mode trunk
!
interface Vlan7
description VLAN fuer VDSL
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username @t-online.de password 0
[/sourcecode]

VDSL mit Cisco Routern

[sourcecode]
!
interface FastEthernet3
description WAN to VDSL-Modem
switchport mode trunk
!
interface Vlan7
description VLAN fuer VDSL
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username @t-online.de password 0
[/sourcecode]