Category Archives: Cisco

Ubuntu on WAVE

Ha geht doch. Linux auf der WAVE

WAVE-274# copy ftp disk 192.168.200.5 / ubuntu-8.10-server-i386.iso /local1/vbs
WAVE-274# conf t
WAVE-274(config)# virtual-blade 1
WAVE-274(config-vb)# boot cd-image disk /local1/vbs/lxserver.iso
WAVE-274(config-vb)# exit
WAVE-274(config)# exit

WAVE-274#sh virtual-blade 1
virtual-blade 1
config:
device cpu qemu32
device nic rtl8139
device disk IDE
memory 512
disk 10
no boot fd-image
boot cd-image disk /local1/vbs/lxserver.iso
boot from cd-rom
interface 1 bridge GigabitEthernet 1/0 mac-address 00:16:3E:FF:FF:FF
no autostart
state:
stopped

WAVE-274#virtual-blade 1 start

Auf dem PC dann:

Nach der Installation traf es mich dann:

WAVE-274# reload

Das Boot device lies sich nur mit aus geschalteter VM um biegen. Kann sein das ich ein wenig ungeduldig war:-)

Etwas mehr gedult und das geht auch.

Noch einmal von CD Starten und Installiertes System starten.

WAVE-274#sh virtual-blade 1
virtual-blade 1
config:
device cpu qemu32
device nic rtl8139
device disk IDE
memory 512
disk 10
no boot fd-image
boot cd-image disk /local1/vbs/lxserver.iso
boot from cd-rom
interface 1 bridge GigabitEthernet 1/0 mac-address 00:16:3E:17:DF:5C
no autostart
state:
stopped
WAVE-274#conf t
WAVE-274(config)#virtual-blade 1 boot from disk
WAVE-274(config)#
WAVE-274#virtual-blade 1 start

und voilà!

Windows on WAVE

Hm der Test mit Ubuntu von CD ROM war nicht ganz erfolgreich.
Das wollte einfach nicht starten.

Heute der Versuch mit dem Windows 2008 Server ISO File verlief dann schon besser :-) aber noch ist nicht aller Tage abend.

Also auf Console commt man mit dem vncclient 192.168.200.2:1

Also dann viel Spass.
--- snip ---
virtual-blade enable
virtual-blade 1
device cpu qemu32
device nic rtl8139
device disk IDE
memory 512
disk 10
boot cd-image disk /local1/vbs/winserver.iso
boot from cd-rom
interface 1 bridge GigabitEthernet 1/0
  no autostart
exit
--- snip ---

Dann
wae# copy ftp disk 192.168.200.5 / winserver.iso /local1/vbs/winserver.iso
und dann
wae# virutal-blade 1 start

auf dem PC dann

Cisco WAAS Installation and Configuration Guide for Windows on a Virtual Blade

He mein neuer PC ist da.


Heute kammen die neuen WAVE Boxen von Cisco an die WAVE-274 sieht aus wie ein PC.
Na das beste ist auf dem Ding kann man auch noch eine Virtuele Machine laufen lassen:-)

Cisco Wide Area Application Engine Console

Username: admin
Password:
System Initialization Finished.
WAVE-274#sh ver
Cisco Wide Area Application Services Software (WAAS)
Copyright (c) 1999-2008 by Cisco Systems, Inc.
Cisco Wide Area Application Services Software Release 4.1.1c (build b16 Nov 5 2
008)
Version: oe274-4.1.1c.16

Compiled 10:10:31 Nov 5 2008 by cnbuild

System was restarted on Thu Dec 4 08:56:47 2008.
The system has been up for 5 minutes, 22 seconds.

WAVE-274#sh virtual-blade 1
virtual-blade 1
config:
device cpu qemu64
device nic rtl8139
device disk IDE
memory 512
disk 10
no boot fd-image
no boot cd-image
boot from disk
interface 1 bridge GigabitEthernet 1/0 mac-address 00:16:3E:FF:FF:FF
no autostart
state:
stopped

Mein Router hat 8GB Flash

Wow wer hätte das gedacht das man das mit einem einfachen USB Stick von CN machen kann.

Router#
*Nov 24 15:46:07.183: %USBFLASH-5-CHANGE: usbflash0 has been inserted!
Router#dir usbflash0:
Directory of usbflash0:/

8345026560 bytes total (6941126656 bytes free)
Router#
*Nov 24 15:46:24.183: %USBFLASH-5-CHANGE: usbflash0 has been removed!
*Nov 24 15:46:24.419: %USB_HOST_STACK-5-USB_ENUM_FAIL_GETDESCR: Failed to enumerate a USB device as not able to read the device’s description.
Router#

Upgrade 2800 series router to support USB boot

Die 2800 und 3800er Router scheinen von USB booten zu können aber die 1800er (1812) noch nicht.

Block Skype Traffic on Cisco Router

Die Ciscos haben ein neues Konzept für die IOS Firewall implementiert. Mit dieser sollte auch das blocken von Skype möglich sein.

ZoneBased Firewall

Auf dem Ansatz der alten Lösung, Link, werd ich das ganze mal auf die ZBF übertragen.

Hier der erste Ansatz:

--- snip ---
class-map type inspect http block-skype-class
match request method connect
!
class−map type inspect match−any private−allowed−class
match protocol tcp
match protocol udp
match protocol icmp
!
policy-map type inspect inside-outside-policy
class type inspect http block-skype-class
 drop
 log
class type inspect private−allowed−class
 inspect
class class-default
!
! the good
zone security inside
!
! the bad 
zone security dmz
!
! and the ugly
zone security outside
!
! combine inside and outside
! traffic goes from inside to outside
zone-pair security inside-outside source inside destination outside
service-policy type inspect inside-outside-policy
!
interface FastEthernet 0
zone-member security inside
!
interface FastEthernet 1
zone-member security outside
!
--- snip ---

Block Skype Traffic on Cisco Router

Die Ciscos haben ein neues Konzept für die IOS Firewall implementiert. Mit dieser sollte auch das blocken von Skype möglich sein.

ZoneBased Firewall

Auf dem Ansatz der alten Lösung, Link, werd ich das ganze mal auf die ZBF übertragen.

Hier der erste Ansatz:

--- snip ---
class-map type inspect http block-skype-class
match request method connect
!
class−map type inspect match−any private−allowed−class
match protocol tcp
match protocol udp
match protocol icmp
!
policy-map type inspect inside-outside-policy
class type inspect http block-skype-class
 drop
 log
class type inspect private−allowed−class
 inspect
class class-default
!
! the good
zone security inside
!
! the bad 
zone security dmz
!
! and the ugly
zone security outside
!
! combine inside and outside
! traffic goes from inside to outside
zone-pair security inside-outside source inside destination outside
service-policy type inspect inside-outside-policy
!
interface FastEthernet 0
zone-member security inside
!
interface FastEthernet 1
zone-member security outside
!
--- snip ---

VDSL mit Cisco Routern

[sourcecode]
!
interface FastEthernet3
description WAN to VDSL-Modem
switchport mode trunk
!
interface Vlan7
description VLAN fuer VDSL
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username @t-online.de password 0
[/sourcecode]

VDSL mit Cisco Routern

[sourcecode]
!
interface FastEthernet3
description WAN to VDSL-Modem
switchport mode trunk
!
interface Vlan7
description VLAN fuer VDSL
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache policy
ip route-cache flow
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username @t-online.de password 0
[/sourcecode]